Firefox/Input/Releases/3.2/Refactoring

From MozillaWiki
< Firefox‎ | Input‎ | Releases‎ | 3.2
Jump to: navigation, search

Refactor

  • move stuff from feedback/__init__.py to input/__init__.py bug 630668
    • products
    • versions
    • operating systems
  • add commonly used template items to context preprocessors
  • liberate helpers to jingo bug 630677
  • liberate version compare code bug 630678
  • populate() should move to input, perhaps, and out of cron.py
  • ensure new sandbox installs work out of the box (e.g. fix migration issues): bug 630669
    • Create initial migration instead of running syncdb (ever)
    • We can remove old migrations entirely.
    • Bundle the new_data.sh script that I use to get new data ;)
  • move common templates from /dashboard to /input
  • move MAX_*_LENGTH out of settings (should be in opinion type in input/__init__.py) bug 630679
  • Consolidate Terminology: bug 630670
    • happy -> praise
    • sad -> issues
    • idea -> suggestion
    • app -> product
    • operating_system -> platform
  • Look for long files bug 630676
  • Statically read over code and get a feel for the site <- helps find places to refactor
  • More upstreamy!
  • less locals() in helpers bug 630673
  • find a better way to serve mobile and desktop templates from the same view bug 630674
  • make version lists suck less (bug 627544)

Tests

  • check.py
  • jslint
  • coverage -> 100%
    • (is Hudson+cobertura now usable?)
      • no the bug is still open, I run coverage locally

Documentation:

  • feedback.cron.populate
  • README is out of date (see syncdb above)
  • point at playdoh for some of the more general topics
  • sphinxsearch stuff could be better
  • how a moz dev can easily pull in a test data set <- that script of mine - for actual data, but we should push people to use populate() since it's awesome

IT stuff (Side-track):

  • access to run management commands in stage
  • rackspace clone of input (fake data)

CSS/JS:

  • Refactor this by hand :(
  • Prefix all js based styles with js_ e.g. js_visible, js_invisible, etc. Makes it easy to grep for stuff that isn't used anymore.

Github:

  • Make repo owner Mozilla
  • Rename reporter to fxinput (?)

Sphinx:

  • Upgrade

POST-METRICS-REVOLUTION!!!:

  • Rename website_issues to websites
  • Get rid of that damn extra database that causes me stress
  • give dd chill pill <-lol