QA/Desktop Firefox/Releases/Configs/Fx57b14

From MozillaWiki
< QA‎ | Desktop Firefox‎ | Releases‎ | Configs
Revision as of 08:47, 3 November 2017 by Bogdan.maris (talk | contribs) (Created page with "== Update tests: beta* channels == * '''Note: adjust channel=<channelUnderTest> accordingly''' * '''Watersheds and special notes''' ** <font style="color: red; font-weight:bol...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Update tests: beta* channels

  • Note: adjust channel=<channelUnderTest> accordingly
  • Watersheds and special notes
    • Update tests support Firefox versions up to 3 releases back, or the last ESR Release - e.g. for Firefox 57 we support testing updates from Firefox 54
    • 56.0b3 is an update watershed for all operating systems
    • WINDOWS
      • 53+ - support dropped for Windows XP and Vista
        • Moved XP locales to the other Windows machines:
          • fr & ta - [windows 7 32bit] - platform=win32
          • es-MX - [windows 7 64bit] - platform=win32
          • pl - [windows 8.1 32bit] - platform=win32
          • he - [windows 8.1 64bit] - platform=win32
          • gu-IN - [windows 7 64bit] - platform=win64
          • pt-BR - [windows 8.1 64bit] - platform=win64
      • 47.0.2 - is an update "watershed" for Windows, no versions from before go to builds beyond it (used to be 48.0.2) - see bug 1284903 - applies to release builds
      • Versions < 48.0 - will only update to 47.0.2 (used to be 47.0.1), because these versions update further only if the Websense hotfix is installed, and Websense is not detected - see bug 1298404 - applies to release builds (may apply to Beta builds as well)
      • 48.0RC2 - is an update "watershed" for Windows, no versions from before go to builds beyond it
        • This used to be 48.0b1 - see comment in bug 1284901 and bug 1271762 - but this was corrected by Justin Wood (email sent to release-drivers on Sep 20)
        • 48.0 Beta builds will update directly to latest Beta (50) and not go through RC
      • 48.0b8 - was cancelled so there is no build available
    • MAC OS X
      • 49+ - support was dropped for Mac OS X 10.6-10.8 starting with version 49 (users will get a deprecation notice) - see bug 1275607 - also versions <48.0.1 will be updated to 48.0.1
    • LINUX
      • 45.0.2 - is an update "watershed" for Linux (users with GTK >= 3.4 will get updated further to the latest available build, others will stay on 45.0.2 - ondemand update Linux machines have GTK > 3.4 so they should update to the latest version) - bug 1270358
    • LOCALE UPDATES:
      • "my" - added in 54.0b2 - added added under [windows 7 64bit] - platform=win32

Win 32 builds config file

[testrun]
script=update
target-version=57.0b14#1
channel=beta-cdntest

[windows 7 32bit]
platform=win32
57.0b13=en-US ta
57.0b12=th
57.0b11=ar
57.0b10=is
57.0b9=fr
57.0b8=nl
56.0b12=kk
55.0b13=ru
54.0b10=km

[windows 7 64bit]
platform=win32
57.0b13=en-US mk
57.0b12=lij
57.0b11=lt
57.0b10=de
57.0b9=es-MX
56.0b12=uz
55.0b12=my
54.0b9=an

[windows 8.1 32bit]
platform=win32
57.0b13=en-US gn
57.0b12=xh
57.0b11=ms
57.0b10=uk
57.0b9=pl
56.0b12=vi
55.0b11=pt-PT
54.0b6=rm

[windows 8.1 64bit]
platform=win32
57.0b13=en-US ml
57.0b12=te
57.0b11=pa-IN
57.0b10=zh-CN
57.0b9=he
56.0b12=cak
55.0b10=son
54.0b5=sl

[mac 10.9 64bit]
platform=mac
57.0b13=en-US nn-NO
57.0b12=tr
57.0b11=dsb
57.0b10=af
57.0b9=ca
56.0b12=en-GB
55.0b13=mr
54.0b10=cs

[mac 10.10 64bit]
platform=mac
57.0b13=en-US sq
57.0b12=as
57.0b11=ast
57.0b10=ach
57.0b9=ro
56.0b12=zh-TW
55.0b12=ka
54.0b9=it

[mac 10.11 64bit]
platform=mac
57.0b13=en-US bn-BD
57.0b12=bn-IN
57.0b11=hi-IN
57.0b10=br
57.0b9=fi
56.0b12=es-ES
55.0b11=fa
54.0b8=ja-JP-mac

[linux ubuntu 14.04 32bit]
platform=linux
57.0b13=en-US eu
57.0b12=ko
57.0b11=hu
57.0b10=sr
57.0b9=es-AR
57.0b8=gd
56.0b12=si
56.0b11=hr
56.0b10=mai
56.0b9=da
55.0b13=el
54.0b10=sv-SE

[linux ubuntu 14.04 64bit]
platform=linux64
57.0b13=en-US fy-NL
57.0b12=ja
57.0b11=nb-NO
57.0b10=id
57.0b9=or
57.0b8=hsb
56.0b12=kn
56.0b11=es-CL
56.0b10=lv
56.0b9=hy-AM
55.0b13=gl
54.0b9=ga-IE

Win 64 builds config file

[testrun]
script=update
target-version=57.0b14#1
channel=beta-cdntest

[windows 7 64bit]
platform=win64
57.0b13=cy
57.0b12=gu-IN
57.0b10=bg
57.0b8=bs
56.0b12=en-US
55.0b13=en-US
54.0b9=az

[windows 8.1 64bit]
platform=win64
57.0b13=pt-BR
57.0b12=en-US
57.0b11=eo
57.0b9=et
56.0b12=ff
55.0b13=kab
54.0b10=en-ZA