Personal tools

Bugzilla:Prerequisites

From MozillaWiki

Jump to: navigation, search

Contents

Fedora / RHEL / CentOS

The vast majority of Bugzilla's prerequisites are available in RPM form either from the distro or from RPMForge. Instructions for setting up yum, apt, or up2date to download from RPMForge automatically are available at http://rpmforge.net/user/faq/. You may need to enable the rpmforge-extras repository to get all the packages you need.

Here's a yum command listing most of the required and optional dependencies of Bugzilla:

yum install httpd mysql-server mod_perl mod_perl-devel httpd-devel graphviz patchutils gcc perl-DateTime perl-Template-Toolkit perl-Email-Send perl-Email-MIME perl-GD perl-Chart perl-Template-GD perl-GDGraph perl-GDTextUtil perl-PatchReader perl-MIME-tools perl-LDAP perl-Authen-SASL perl-RadiusPerl perl-SOAP-Lite perl-JSON-RPC perl-JSON-XS perl-Test-Taint perl-HTML-Scrubber perl-Email-MIME-Attachment-Stripper perl-Email-Reply perl-TheSchwartz perl-Daemon-Generic perl-Math-Random-Secure perl-YAML perl-Class-Inspector

If you are running RHEL6, you will have to enable the "RHEL Server Optional" channel in RHN to get some of those packages.

Ubuntu

To get the official version (as opposed to Debian's version) of Bugzilla working on Ubuntu, you need to install the base system and the following packages:

Required:

apache2 mysql-server libappconfig-perl libdate-calc-perl libtemplate-perl libmime-perl build-essential libdatetime-timezone-perl libdatetime-perl libemail-send-perl libemail-mime-perl libemail-mime-modifier-perl libdbi-perl libdbd-mysql-perl libcgi-pm-perl libmath-random-isaac-perl libmath-random-isaac-xs-perl

Optional:

apache2-mpm-prefork libapache2-mod-perl2 libapache2-mod-perl2-dev libchart-perl libxml-perl libxml-twig-perl perlmagick libgd-graph-perl libtemplate-plugin-gd-perl libsoap-lite-perl libhtml-scrubber-perl libjson-rpc-perl libdaemon-generic-perl libtheschwartz-perl libtest-taint-perl libauthen-radius-perl libfile-slurp-perl libencode-detect-perl libmodule-build-perl libnet-ldap-perl libauthen-sasl-perl

Even More Optional:

libtemplate-perl-doc bzr

You will then find that some modules are too old, and you have to install them manually using the install-module.pl script, as checksetup.pl tells you.

Note also that if you want to interact with Bugzilla's bzr repo, you need at least bzr 2.0.

Debian Lenny

REQUIRED MODULES                  VERSIONS           apt-get install

CGI.pm (v3.33)                ok: found v3.38        libcgi-pm-perl
TimeDate (v2.21)              ok: found v2.22        libtimedate-perl
PathTools (v0.84)             ok: found v3.2501      already installed with standard install
DBI (v1.41)                   ok: found v1.605       libauthen-simple-dbi-perl
Template-Toolkit (v2.15)      ok: found v2.19        libtemplate-perl
Email-Send (v2.00)            ok: found v2.192       libemail-send-perl
Email-MIME (v1.861)           ok: found v1.861       libemail-mime-perl
Email-MIME-Modifier (v1.442)  ok: found v1.442       libemail-mime-modifier-perl

PERL DBD MODULES
DBD-Pg (v1.45)                ok: found v2.8.7       libdbd-pg-perl
DBD-mysql (v4.00)             ok: found v4.007       mysql-server-5.0

OPTIONAL MODULES
GD (v1.20)                   ok: found v2.39         lib-chart-perl
Chart (v1.0)                 ok: found v2.4.1        lib-chart-perl
Template-GD (any)            ok: found v1.56         libtemplate-pg-perl
GDTextUtil (any)             ok: found v0.86         libgd-graph-perl
GDGraph (any)                ok: found v1.44         libgd-graph-perl
XML-Twig (any)               ok: found v3.32         libxml-twig-perl
MIME-tools (v5.406)          ok: found v5.427        libmime-perl
libwww-perl (any)            ok: found v5.813        libwww-perl
PerlMagick (any)             ok: found v6.3.7        perlmagick
perl-ldap (any)              ok: found v0.36         libauthen-simple-ldap-perl
Authen-SASL (any)            ok: found v2.12         libauthen-sasl-perl
RadiusPerl (any)             ok: found v0.13         libauthen-simple-radius-perl
SOAP-Lite (any)              ok: found v0.710.08     libsoap-lite-perl
HTML-Parser (v3.40)          ok: found v3.56         libhtml-parser-perl
HTML-Scrubber (any)          ok: found v0.08         libhtml-scrubber-perl
mod_perl (v1.999022)         ok: found v2.000004     libapache2-mod-perl2

There are currently no available deb packages for the following modules:

DBD-Oracle (v1.19)
PatchReader (v0.9.4)
Email-MIME-Attachment-Stripper (any)
Email-Reply (any)

In order to get them, run the following commands in your Bugzilla directory:
/usr/bin/perl -MCPAN -e 'install "DBD::Oracle"'
/usr/bin/perl -MCPAN -e 'install "PatchReader"'
/usr/bin/perl -MCPAN -e 'install "Email::MIME::Attachment::Stripper"'

apt-get install libemail-mime-creator-perl
/usr/bin/perl -MCPAN -e 'install "Email::Reply"'

FreeBSD 7.x

If you're using FreeBSD 7.x, you can install these packages to get you going:

        apache
        mysql50-server
        p5-Digest-SHA
        p5-TimeDate
        p5-DateTime
        p5-DBI
        p5-Template-Toolkit
        p5-Email-Send
        p5-Email-MIME
        p5-Email-MIME-Modifier
        p5-DBD-mysql
        p5-GD
        p5-Chart
        p5-Template-GD
        p5-XML-Twig
        p5-MIME-Tools
        p5-perl-ldap
        p5-SOAP-Lite
        p5-HTML-Scrubber
        p5-Email-MIME-Attachment-Stripper
        p5-Email-Reply
        p5-TheSchwartz
        p5-GD-Graph

This is using the "stable" 7 release package tree, NOT the 7.x release tree. Just add this to your /etc/csh.cshrc:

setenv PACKAGESITE ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-7-stable/Latest/

Source via CPAN

If you are using a distro that doesn't have packages readily available, or are behind a firewall that restricts outbound traffic and you need to install things manually, the following are the upstream sources for Bugzilla's prerequisites.

I plan to have direct links for each module here soon, but in the meantime, you can find them by setting the search type to "Module" and searching for the module name on CPAN. You can install Bundle::Bugzilla, it is outdated, but will install many of prerequisites. You can install it automatically using CPAN or CPANPLUS shells.