Changes

Jump to: navigation, search

Talk:WebAPI/WebTelephony

435 bytes added, 20:48, 30 November 2011
philikon's thoughts
== philikon's thoughts ==
* IMHO  var call = <code>navigator.telephony.dial("numbergoeshere"); </code> is nicer than  var call = <code>new TelephonyCall("numbergoeshere");</code>
* We have a bunch of telephony-related functionality that's not reflected yet:
** controlling and reading radio power
** reading radio metadata (operator, signal strength, etc.)
** ...
* I would also suggest another readyState, <code>"dialing"</code> that comes before <code>"calling"</code> for outgoing calls.
* Nits: we should probably define the possible values for readyState on the interface (nit: for XHR they're ints, not strings... I like being consistent, but I also prefers strings... hmmm...). Also, event listener objects should probably be declared as <code>EventListener</code>.
My proposal on this (as a delta to the main proposal):
interface Telephony {
void power(bool on);
Some thoughts on this:
TelephonyCall dial(String number);
EventListener onpowerchange
EventListener onsignalstrengthchange
EventListener onoperatorchange
}
Canmove, confirm
725
edits

Navigation menu